Libstdc++ too old

出自WPS For Linux

跳转到: 导航, 搜索

当您看到此页面,说明您的linux系统的libstdc++库版本过低,导致wps无法启动。

请参照以下步骤解决此问题:


1 获取一个新版本的libstdc++

注: 这只是获取libstdc++的一种方法,任何方法获取libstdc++,只要版本大于4.5都可以

http://packages.debian.org/sid/i386/libstdc++6/download ,下载一个包含libstdc++的deb文件

解压deb文件

$ ar vx 你下载的deb文件

$ tar xvf data.tar.gz

解压后的./usr/lib/i386-linux-gnu/libstdc++.so.6.0.17就是我们需要的文件 # 后面版本后可能随下载的文件不同略有区别


2 将获取的libstdc++.so放入wps的office6目录

一般来说,如果通过安装包安装,wps的office6目录一般位于/opt/kingsoft/wps-office/office6,如果是绿色版请放入相应目录

以上述获取的文件为例

$ sudo cp path_to_libstdc++/libstdc++.so.6.0.17 /opt/kingsoft/wps-office/office6/libstdc++.so.6


3 检验

$ cd /opt/kingsoft/wps-office/office6 # 如果wps安装在其他目录,请对应修改路径

$ ldd wps > /dev/null

如果输出没有输出,或输出中不包含libstdc++,说明问题成功解决。

个人工具